Cloudflare upload speed tests failing

Incident Report for Orb

Resolved

The upstream issue has been resolved and uploads are working again. We will continue to monitor the situation.
Posted Jul 07, 2026 - 10:04 UTC

Monitoring

We have released Orb sensor v1.5.2 with a workaround for this issue.
Orb app 1.5.3 release is in progress with a workaround for this issue - it is currently available for Windows and Android.
You can update to resolve this issue right away on your devices.
Posted Jul 07, 2026 - 00:06 UTC

Identified

A recent change in Cloudflare API behavior is causing upload speed tests to fail. We are working with Cloudflare to resolve the issue.
Posted Jul 06, 2026 - 21:45 UTC
This incident affected: Cloudflare Network.