Slow Cloud Analytics

Incident Report for Orb

Resolved

The upstream provider has resolved the issue and rendering speeds are back to normal
Posted Jan 09, 2026 - 10:17 UTC

Identified

Our upstream analytics provider is having issues rendering some of our analytics views, this results in slow rendering charts. We are working with our provider to get this resolved.
Posted Jan 08, 2026 - 18:56 UTC
This incident affected: Orb Cloud.