The upstream provider seems to have resolved their outage, we'll keep monitoring the situation.
Posted Jun 12, 2025 - 18:55 UTC
Update
We have identified the origin of the issues. One of our upstream providers is having an outage. We will keep this page updated as we receive more information.
Posted Jun 12, 2025 - 18:22 UTC
Identified
The issue has been identified and a fix is being implemented.